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Introduction
This document provides guidance on how to use the odt2daisy extension for OpenOffice.org.

Installation

Odt2daisy is simple to install:
– open OpenOffice.org 3
– select "Extension Manager …" in the "Tools" menu
– click "Add..." , and select the downloaded oxt file
– restart OOo

After the installation and restart, you should find the following in OpenOffice Writer:
– an “Export As DAISY XML” button in the toolbar
– an “Export As Full DAISY” button in the toolbar
– an “Export As DAISY XML” menu item in the “File” menu
– an “Export As Full DAISY” menu item in the “File” menu
– a set of templates in  the “DAISY Books” folder
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Illustration 1: Odt2daisy appears in the extension manager after installation
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Illustration 2: "Export As DAISY XML" option in the OpenOffice.org Toolbar

Illustration 3: "DAISY Books" templates folder



Export as DAISY XML 
To export a document as DAISY XML (without audio), select “Export as DAISY XML” in the 
“File” menu or use the DAISY XML button on the toolbar. The “Export Dialog” section describe 
how to fill the export dialog properly.

Export as Full DAISY
A Full DAISY book contains both an audio and a text version of the content, and structure 
information. 

odt2daisy generates the audio version of an OpenOffice.org document by using the TTS engines or 
“voices” installed on your operating system. For this reason, the quality of the audio and the 
languages that can be produced depend on the TTS engines that are installed on your computer.

Note: “Asian” and “Complex Text Layout” (CTL) languages are not supported.

Microsoft Windows

The English versions of Microsoft Windows (XP, Vista and 7) embed an English TTS engine,
so you can produce Full DAISY books in English out of the box.

In order to produce better quality audio and audio in multiple languages, you can use third-party 
TTS engines, such as:

– Cepstral Voices (http://cepstral.com/)

– Dolphin Voices (http://www.yourdolphin.com/)

– InfoVox Voices (http://www.acapela-group.com/)

– or any other SAPI5-compatible TTS voices 

Linux, Solaris and Open Solaris

On Linux, Solaris and Open Solaris odt2daisy uses the eSpeak TTS engine (already included by 
default in many cases).
Odt2daisy can produce Full DAISY books in all “Western” eSpeak voices, including:

– English

– French

– Spanish

– Italian

– German

More information about eSpeak TTS can be found on the official website 
http://espeak.sourceforge.net/.

You can also use third-party voices such as those from Loquendo or IBM.
In that case, you will need to edit the ttsbuilder.xml file installed at: 
~/.pipeline-lite/transformers/se_tpb_speechgen2/tts/ttsbuilder.xml
Note: More informations can be found here: http://www.daisy.org/forums/node/136.
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Mac OS X (PowerPC and Intel) 

Odt2daisy is compatible with Mac OS X. You can produce Full DAISY books in English out of the 
box using “Alex” VoiceOver.

You can also use third party voices such as:

– Cepstral Voices (http://cepstral.com/)

– InfoVox Voices (http://www.acapela-group.com/)

– or any other TTS voice compatible with VoiceOver

When using a third-party voice, you need to edit ttsbuilder.xml file installed at: 
~/.pipeline-lite/transformers/se_tpb_speechgen2/tts/ttsbuilder.xml
Note: More informations can be found here: http://www.daisy.org/forums/node/136.
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Illustration 4: Export As Full DAISY dialog on Mac OS X

http://www.daisy.org/forums/node/136
http://www.acapela-group.com/
http://cepstral.com/


Export Dialog

Note: During an export as DAISY XML, the export dialog don't include bitrate, fix routines, and 
sentence detection since these parameters are used for audio generation.

UID

The UID is a universally unique identifier for your DAISY book. The UID is generated 
automatically, but you can specify your own UID if you prefer.

Title

DAISY Book Title. This field will be empty if you have not filled in the title of the file in the file  
properties. You can also set the title of the file in the Properties dialog in the File menu in 
OpenOffice.org: in the Properties dialog, go to the Description tab and fill in the Title field.

Creator

The author of the DAISY book. This field is filled automatically with user data from 
OpenOffice.org. If the field is empty and you want it to be automatically filled with your name, you 
can also set your first name and last name in the Options dialog under the Tools menu: go to “User 
data” (in the OpenOffice.org section of the options) and fill in your first name and/or last name.  

Publisher

The agency responsible for making the DAISY book available. 
Odt2daisy uses the value in Creator as default value.
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Producer

The organization that created the DAISY book. 
Odt2daisy uses the value in Creator as default value.

Language

The main language of the document must be set in Tools > Language > For all Text... > Language.

Odt2daisy can produce multilingual books. 
If the document contains paragraphs in a language that is different from the default language, you 
should set the language of that paragraph by using Tools > Language > For Paragraph.
If the document contains words or phrases in a language that is different from the immediately 
surrounding text, you should set the language of that word or phrase by using Tools > Language > 
For Selection.

Page Numbers

Basic Numbering

If your document contains page numbers, you can choose to include them in your DAISY book. If 
you check the box “include page numbers”, all pages that have a footer or a header with a “Page 
Number field” will have page number in DAISY.

If your document does not contain page numbers, you add them by following these steps:

– Go to Insert > Footer (or Header) > Default. This adds an empty footer (or header) section to 
your document.

– Go to Insert > Fields > Page Number.

– You can change the alignment of the page number in the Paragraph dialogue under the 
Format menu or by using the alignment buttons on the toolbar.

Advanced Numbering

Odt2daisy allows several pages to be numbered as a single page in the DAISY book.

If you want to output two or more pages in OpenOffice.org as a single DAISY page, proceed as 
follows: 

– Create a new Page Style, named “NoPageNumber” (or any other name you find more 
appropriate) without any Page Number in header or footer.

– Write the first page with a page style including a Page Number in header or footer, for 
example page number 3

– Write the other pages using the page style named “NoPageNumber”

– At the last page, insert a page break, change style to a Page Numbered Style, and change the 
page number to what would be the next page number, in this example page 4.
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Alternate Level Markup

If you check “use alternate level markup”, your DAISY book will use <level depth=''N''> notation 
instead of <levelN>.

It must be checked if your book use “Heading 7” Style and higher.

Including CSS

If you check “include CSS”, odt2daisy will also produce a CSS file.

This CSS file allows to view your DAISY book in a browser.

Bitrate

Selects the bit rate of the generated MP3 audio files. A higher value will result in better sound 
quality but the audio files will be larger. The default value is 32 kbit/s.

Fix Routines

Selects whether to apply DAISY book fix routines to the input document. These routines try to 
clean and possibly repair the input DAISY XML document to enforce the best compatibility with 
the remaining steps. This option is recommended.

Sentence detection

Selects whether to apply sentence detection to the input document text to enable a finer-grained 
audio synchronization.
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Conversion Errors
If you conversion error occurs during the export process, odt2daisy will show a warning.

It is important to fix any errors in the source document before exporting the DAISY book. It is 
highly discouraged to use or distribute an invalid DAISY Book. A common cause of errors is the 
incorrect use of heading levels, for example if the first heading after a Heading 1 is a Heading 3 
instead of a Heading 2, the resulting DAISY book will not be valid.

DAISY format is “structure centered” so your OpenOffice.org document have to be well structured.
Please respect accessibility rules for a better document.
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Illustration 5: Example of an error: an heading 1 followed by an heading 3



Accessibility Rules 
You should start to check these points before going further during an export as DAISY error or 
simply for produce more accessible DAISY books:

✔ Check the Heading structure of your document using the OpenOffice.org Navigator 
(View > Navigator > Headings)

• Avoid gaps (Heading 1 followed by an Heading 3)

• Avoid blank headings

• Avoid headings in frames

• Avoid headings in sections

✔ Search hidden structure issues by showing Non printing characters
(“View” > “Nonprinting Characters”)

• remove empty lists

• keep in mind that a new paragraph (key “Enter”) is different than a break line (keys 
“Shift + Enter”)

✔ Use simple tables 

• with headings (“Insert” > “Table...” and check heading)

• avoid nested tables (A table included in another one)  

✔ Use JPEG, PNG or SVG pictures only

✔ Fill alternative text. It should be relevant and must be different if you have a caption. 

• Picture: right click > “Picture...” then select the “Options” tab and fill “Alternative (Text 
only)” field.

• Formula: right click > “Object...” then select the “Options” tab and fill “Alternative 
(Text only)” field.

✔ Fill language of each part of your document (selection, paragraph and all text). 
This step is crucial for “Export as DAISY” during audio generation

• start by setting the main language of the document
(Tools > Language > For all Text)

• set every words or any selection of the document with a different language
(Tools > Language > For Selection)

• set every paragraphs of the document with a different language 
(Tools > Language > For Paragraph)

✔ Use OpenOffice.org styles for formatting your document

✔ Use DAISY styles (name start with “[DAISY]”) to enrich the structure
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Major Structural Elements
The instructions in the first part of this manual explain how to produce simple DAISY books. The 
next part of the manual provides information for people who want to create DAISY from more 
complex documents, or who want to use more complex DAISY features.

Metadata

Subject and Keywords metadata can be set in File > Properties > Description.
Keywords must be separated by a comma.

Front, Body, Rear Matter

Basic Front Matter

The front matter is automatically managed by the translator.
It will include everything before the first “Heading 1” inside a <level1 class=''title_page''>.

Advanced Front Matter

You can specify the front matter with a Section named “BodyMatterStart”.
In that case, the front matter will be everything before this section.

Note: “Advanced DAISY Book” template can be a good start.

Advanced Rear Matter

Rear matter can be defined with a Section named “RearMatterStart”.
In that case, rear matter start after it.

Note: “Advanced DAISY Book” template can be a good start.

Levels 

Levels are mapped with Heading 1, Heading 2, …, Heading X Styles.
You should have a correct Heading markup to produce a DAISY book.
This means you cannot have a Heading 3 just after an Heading 1, for example.

Part, Chapter, Section, Subsection Levels

You can produce levels with Part, Chapter, Sections and Subsection class attributes.
For example, if your level1 is a “Part” , specify it like this:

– go to File > Properties > User Defined

– click on “Info fields...” and change “Info 1” to “DAISY TOP LEVEL”

– put “Part” as value (others values are “Chapter” and “Section”)

“Part” value will map level1 to part, level2 to chapter, level3 to section, level4 to subsection.
“Chapter” value will map level1 to chapter, level2 to section, level3 to subsection.
“Section” value will map level1 to section, level2 to subsection.
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Note: “Part DAISY Book”, “Chapter DAISY Book” and “Section DAISY Book” templates can be a 
good start.

Inline Elements

Native Inline Elements

Bold, Italic, Emphasis Style, Strong Emphasis Style, Subscript and Superscript, Emails and 
Hyperlinks are natively supported, so they can be used as usual.

Anchor

Anchors can be produced using a bookmark (Insert > Bookmark, Insert > Cross Reference)

Custom Styles

DAISY templates include custom styles to produce some DAISY inline elements. 
You can find them in Character Styles if you started your document from a DAISY template.
You can also load the DAISY Style using the “Formatting and Styles dialog”.
The custom styles for DAISY inline elements are:

– Abbreviation

– Acronym

– Acronym (Pronounce)

– Blockquote

– Computer Code

– Keyboard Input

– Prodnote

– Prodnote (Optional)

– Sample

– Sentence

– Span
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Block Elements

Lists

Lists and numbered lists are supported natively so you can produce unordered lists, or numbered 
lists as usual.
It is also possible to use nested lists like this:

1) Windows

2) Linux

a) Ubuntu

b) Fedora

3) Mac OS X

Tables

Tables and nested tables are supported natively so you can manage them as usual.
Complex tables and nested tables are less accessible than simple tables. It is recommended to author 
simple tables with heading like this:

– Insert > Table

– check “Heading” box below “Options”

First Name Last Name

Vincent Spiewak

Greg Kearney

Images

Images are supported natively, you can insert it with: Insert > Picture > from File... 
They will be output in an “images/” directory if you don't check “link” box.

Images without a text alternative are not accessible If an image is not purely decorative, you should 
provide Alternate Text using 
“Right Click” > Picture … > Options > Alternative (text only)

Captions are also supported using “Right Click” > Caption … > Caption field.

MathML

Mathematics are supported natively, you can insert a formula with: Insert > Object... > Formula.
You should also provide a “textual” version of the formula using “Right Click” > “Object...” > 
Alternative (text only)

Notes, Footnotes & Endnotes

Notes, Footnotes and Endnotes are supported natively, so you can use them as usual.
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Sections

Sections are flattened.

For example, this section:

One

Two

Three

Four

Will appear in the DAISY book like this:

One
Two
Three
Four
Warning: Do not use headings inside sections.

Frames

Frames are natively supported, so you can use them as usual.

Warning:

– Do not use headings inside sections !

– Do not use frames within another frame!

Custom Block Elements

The DAISY templates include custom styles to produce DAISY block elements.
You can find them in Paragraph Styles.

These styles are listed below:

– Address

– Author

– Blockquote

– BridgeHead

– ByLine

– DateLine

– Keyboard Input

– Prodnote

– Prodnote (Optional)

– Sample

For example, if you have an address in your document like:
Vincent Spiewak
4 place Jussieu
75005 Paris
France
If these lines are marked up with a “[DAISY]Address” paragraph style,
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Odt2daisy will produce:
<address>

<line>Vincent Spiewak</line>
<line>4 place Jussieu</line>
<line>75005 Paris</line>
<line>France</line>

<address>

Localization
Odt2daisy is easy to localize in other languages.
Please check out this page for more information http://odt2daisy.sourceforge.net/l10n/.
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Frequently Asked Questions

How to install odt2daisy ?

• Open OpenOffice.org 
• in menu "Tools", select "Extension Manager ..." 
• Click on "Add..." button, and then, select the downloaded oxt file 
• Restart OOo 

Now, in a Writer View, you can see the Daisy DTBook Toolbar.
You can dock it in OOo Toolbar by drag-n-drop.

Why odt2daisy works only with OpenOffice.org 3.0 (or grather) ?

Odt2daisy works only with OOo.org 3.0 because it's compatible with ODF 1.2 (or grather).

Why odt2daisy doesn't detect the right document language ?

You need to set the right document language like this in OOO.org with
"Tools" > "Language" > "For All Text" > YOUR LANGUAGE

Why my DAISY book have not pagenum tag ?

Odt2daisy output a pagenum if only a header or a footer is in the page and have a Page Number 
Field. You can do it like this:
"Insert" > "Footer" > "Default", and next "Insert" > "Fields" > "Page Number"

Why the error "Could not create Java implementation loader" occurs 
during installation ?

This error occurs if you didn't install or configure Java JRE properly.
Go to "Tools" > "Options ..." then select "Java" in the list and verify:

• Use a Java runtime environment should be checked 
• A JRE should be selected in "Java runtime environment (JRE) already installed" list 

If this list is empty, you should install a JRE at Java SE Downloads page.

Why the error 
"(com.sun.star.registry.CannotRegisterImplementationException) 
{ { Message = "", Context = com.sun.star.unoXInterface) @0 } } 
Could not create Java implementation loader" 
occurs during installation ?

This error can occurs on some operating systems which doesn't include a proper version of 
OpenOffice.org. You should remove OpenOffice.org and install a new version from official website. 
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More Information
The official odt2daisy website is available at:
http://odt2daisy.sf.net

The website contains a lot of useful information, including:

– Screen-casts

– Forum

– Bug Report 

– Task List (for developer who wants to contribute)

– Donation (only if you like this software :)

You can contact me at vspiewak@sourceforge.net.
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